Odysseyware Academy login page problems.
Incident Report for Odysseyware Status Page
Resolved
This issue has now been resolved and the login page is fully functional again.
Posted 2 months ago. Apr 19, 2017 - 14:34 MST
Identified
Update: the source of the problem is identified and should be completely fixed very soon.
Posted 2 months ago. Apr 19, 2017 - 13:58 MST
Investigating
There are problems logging into the Academy applications. We are currently investigating and will update soon.
Posted 2 months ago. Apr 19, 2017 - 13:20 MST