Odysseyware SIS
Incident Report for Odysseyware Status Page
Resolved
This incident has been resolved.
Posted 16 days ago. Sep 30, 2019 - 14:21 MST
Update
We are continuing to work on a fix for this issue.
Posted 16 days ago. Sep 30, 2019 - 13:52 MST
Identified
The Odysseyware SIS team is performing an emergency hot-fix to address an issue with the system. We apologize for this disruption. More information will be provided shortly.
Posted 16 days ago. Sep 30, 2019 - 13:14 MST
This incident affected: Odysseyware Academy (Genius/SIS).