Slowness accessing the Odysseyware platform
Incident Report for Odysseyware Status Page
Resolved
This incident has been resolved.
Posted Sep 24, 2020 - 10:49 MST
Investigating
Our monitoring systems indicate some Odysseyware customers are experiencing an issue. We are actively working to address the issue and will update this page as more information is available.
Posted Sep 24, 2020 - 09:28 MST
This incident affected: Odysseyware (LMS), Odysseyware Academy (Odysseyware LMS), and Odysseyware Academy (Genius/SIS).