Slowness in the Odysseyware platform
Incident Report for Odysseyware Status Page
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 11:54 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2020 - 11:23 MST
Investigating
An issue in our infrastructure causing slowness accessing the Odysseyware platform has been identified. Our engineering team is addressing this issue as our highest priority.
Posted Sep 15, 2020 - 11:16 MST
This incident affected: Odysseyware (LMS), Odysseyware Academy (Odysseyware LMS), and Odysseyware Academy (Genius/SIS).