Odysseyware Login Error Message
Incident Report for Odysseyware Status Page
Resolved
This incident has been resolved.
Posted Dec 15, 2020 - 09:06 MST
Identified
We have been made aware that some users are having difficulty logging in. If you are having trouble logging in and receiving a message stating: "The information you're about to submit is not secure. Because the site is using a connection that's not completely secure, your information will be visible to others."Please select the "send anyway" option, to bypass the issue. We are actively working to address the issue and will update this page as more information is available.
Posted Dec 14, 2020 - 13:22 MST
This incident affected: Odysseyware (LMS).